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writing in advance by an authorized representative of Alvaria, Inc. Microsoft

Windows®, and Microsoft SQL Server® are registered trademarks or

trademarks of Microsoft Corporation in the United States and/or other

countries. Any other brands, product names, company names, logos,

trademarks, and/or service marks used in this publication are the property of

their respective owners. You may not copy, modify or display any of Alvaria’s

or its affiliates’ or licensors’ trademarks, trade names or logos appearing in

this publication in any way without Alvaria’s express written consent.

The works of authorship, including but not limited to all design, text and

images, contained and the software described in this publication are owned by

Alvaria or its affiliates or licensors, except as otherwise expressly stated. The

entire contents of this publication are protected by United States and

worldwide copyright laws and treaty provisions. In accordance with these laws

and provisions, you may not copy, reproduce, modify, use, republish, upload,

post, transmit or distribute in any way material from this publication. Further,

except as permitted by your written agreement with Alvaria, no part of this

publication may be reproduced, stored in a retrieval system, or transmitted in

any form or by any means, electronic, or otherwise, without the prior written

permission of Alvaria.

RESTRICTED RIGHTS LEGEND

This publication is provided with “Restricted Rights”. No part of this publication

may be photocopied, reproduced or transmitted, in any form or by any means,

without the prior written consent of Alvaria. Use, duplication, or disclosure by

the United States Government (“Government”) is subject to the restrictions set

forth in DFARS 252.227-7013 (b)(3) and FAR 52.227-19. Use of the materials

by the Government constitutes acknowledgement of Alvaria’s proprietary

rights in them. Alvaria is located at 211 Perimeter Center Parkway NE, Suite

250, Atlanta, GA 30346, USA.

LIMITED RIGHTS NOTICE (DEC 2007)

(a) These data are submitted with limited rights under Alvaria’s contracts with

various Government entities. These data may be reproduced and used by the

Government with the express limitation that they will not, without written

permission of the Alvaria, be used for purposes of manufacture nor disclosed

outside the Government; except that the Government may disclose these data
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outside the Government for the following purposes, if any, provided that the

Government makes such disclosure subject to prohibition against further use

and disclosure: None.

EXPORT

This item is subject to U.S. export control laws and regulations. This item may

not be exported, re-exported, re-transferred, disclosed or otherwise diverted

contrary to U.S. export control laws or regulations.

NO WARRANTY

THE CONTENTS OF THIS PUBLICATION ARE PROVIDED “AS IS” WITHOUT

WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT

NOT LIMITED TO, THE IMPLIED WARRANTIES OF QUALITY,

MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, NON-

INFRINGEMENT, OR THAT OPERATION OF THE PRODUCTS SOLD BY ALVARIA

WILL BE UNINTERRUPTED OR ERROR FREE.

NO LIABILITY

ALVARIA, ITS AFFILIATES, AND LICENSORS ARE NOT LIABLE FOR ANY

DAMAGES SUFFERED AS A RESULT OF USING THE CONTENTS OF THIS

PUBLICATION. IN NO EVENT WILL ALVARIA, ITS AFFILIATES OR LICENSORS

BE LIABLE FOR ANY (i) CONSEQUENTIAL, INDIRECT, PUNITIVE, SPECIAL, OR

INCIDENTAL DAMAGES, (ii) ANY INTERRUPTION OF BUSINESS OR

OPERATIONS, COST OF COVER, GOODWILL, TOLL FRAUD, OR LOSS OF DATA,

PROFITS, OR REVENUE, OR (iii) FAILURE OF A REMEDY TO ACHIEVE ITS

ESSENTIAL PURPOSE. THE LIMITATIONS IN THIS SECTION WILL APPLY TO

ANY DAMAGES, HOWEVER CAUSED, AND ON ANY THEORY OF LIABILITY,

WHETHER FOR BREACH OF CONTRACT, TORT, MISREPRESENTATION,

NEGLIGENCE, THE USE OR PERFORMANCE OF A PRODUCT OR SERVICE, OR

OTHERWISE AND REGARDLESS OF WHETHER THE DAMAGES WERE

FORESEEABLE OR UNFORESEEABLE. NEITHER PARTY WILL BE LIABLE FOR

ANY CLAIM BROUGHT BY THE OTHER PARTY MORE THAN 12 MONTHS

AFTER THE OTHER PARTY BECAME AWARE OF THE ISSUE GIVING RISE TO

THE CLAIM. ALVARIA’S, ITS AFFILIATES’ OR LICENSORS’ FAILURE TO

EXERCISE A RIGHT OR REMEDY IS NOT A WAIVER. BECAUSE SOME

JURISDICTIONS PROHIBIT THE EXCLUSION OR LIMITATION OF LIABILITY FOR
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CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY

NOT APPLY TO YOU.

PROGRAMMING AND USE OF PRODUCTS

THE PRODUCTS DESCRIBED IN THIS PUBLICATION CAN BE USED AND

PROGRAMMED IN A WIDE VARIETY OF WAYS BASED ON THE

REQUIREMENTS OF YOUR PARTICULAR TECHNOLOGY, ENVIRONMENT AND

BUSINESS. NOTWITHSTANDING THE USE OF EXAMPLES IN THIS

PUBLICATION OR THE PROVISION OF PROFESSIONAL SERVICES BY ALVARIA,

ALVARIA RESELLERS, OR ANY THIRD PARTY ENGAGED BY ALVARIA, IT IS IN

ALL CASES YOUR RESPONSIBILITY TO ENSURE THAT THE PRODUCTS ARE

PROGRAMMED AND USED IN ACCORDANCE WITH ALL APPLICABLE LAWS

AND REGULATIONS AND IN A MANNER THAT DOES NOT VIOLATE THE

INTELLECTUAL PROPERTY OR OTHER RIGHTS OF ANY THIRD-PARTY.

Rev A

November 7, 2025

About this Guide

This guide helps Aspect Developer Portal users quickly find what they need to

get started and use the portal effectively.

It begins with an Introduction section covering account registration, login

steps, and an overview of key features. It also includes dedicated sections for 

Apps (creating and managing applications and credentials), the API Catalog

(exploring available APIs and documentation), Integrations (HRIS Data

Connect), and Usage (monitoring API activity and performance).

Each section uses collapsible toggles, so you can expand only the topics you

need. Back to top links throughout help you quickly return to the main

sections.

Whether you’re integrating workforce data for the first time or managing

multiple applications, this guide provides step-by-step instructions tailored to

your role and goals.

GDPR Compliance

Overview
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This article describes how to secure user and employee data to comply with

GDPR requirements. 

⚠️ Admin users are not sourced from WFM, so you can delete or

deactivate them directly in the New Experience and maintain GDPR

compliance.

To delete or remove an Employee user, you must use the WFM

procedures because Employee users are sourced from WFM. 

Right to Erasure

Workforce Management satisfies the right to erasure by providing the tools

and procedures documented in this article.

Delete an Employee

You can easily delete an employee you've just added—for example, if you

created an employee record by mistake. However, if the employee has been

associated with other Aspect Workforce Management information, particularly

official schedules, it is usually better not to delete them. Instead, terminate and

inactivate the employee to maintain the integrity of your tracking history,

especially intra-day performance information.

To delete an employee:

1. Open the Workforce Management client.

2. Navigate to Employees > Employee Records.

3. Select the employee to delete and select Special > Change Employee

Status.

4. Terminate the employee, using the Change Employee Status option. 

5. On the Change Employee Status dialog box:

a. Under Employee Status, select the Change To option.

b. Select the Terminated option and specify the termination date. The

termination date must be the current system date or a previous date.
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6. Delete all data records that refer to the employee explicitly and that block

employee deletion. To view these cross-references, select the employee

and select Tools > Show Cross-References, which opens the Cross

Reference Summary dialog box.

7. If the employee is an employee user, use the Users Administration module

to change that user to an inactive, regular user.

8. In the Employee Records grid, select the employee.

9. Select Edit > Delete and confirm your choice when prompted.

⚠️ Deleting the employee removes any remaining cross references,

such as trial schedule assignments. The Cross Reference Summary

dialog box (mentioned in step 6) displays the dependent data types

and the number of records of each type that exist in the database.

The Table below lists these data types and indicates which types

block deletion of an employee record.

Delete a User

As with most types of data, you can delete a selected user by selecting Edit > 

Delete. However, if there is data associated with the user, you must either

delete it first or associate it with another user. The Delete option itself enables

you to easily perform the latter alternative.

After you select Yes at the confirmation prompt, the Delete Users dialog box

opens. Here you can associate a different user with the data associated with

the user, or users, you are deleting. The data associated with a user consists

of various types records that the user created or updated and that have an

Updated By column in the associated grid. If there is no such data, you can

select the second option (Delete the selected users if there is no data

associated with them).

If there is associated data with a user, select the first option (Associate all data

with another user and delete the selected users) and specify a different user

to be associated with the data. For best results, select a “dummy” user that
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you have created only for this purpose, as opposed to an actual user. For

example, you might choose the user name deleted_user.

After you click OK and the deletion is finished, this user name appears in the

Updated By column of all grids containing associated records.

Delete Contact Definition

A Contact Definition is a person whom users can communicate with by the

way of email, instant messaging, or telephone.

To delete a Contact Definition:

1. Navigate to Administration > Contact Definitions, and select the contact

to be deleted.

2. Right-click on the contact and choose Delete.

Delete Autorun

Reports can be sent to email addresses, either using contact definitions or

literal email. Literal emails will need to be found using a SQL command: select

* from AUTORUN_PROC where PROC_PAR LIKE '%John.Doe@aspect.com%'

The autorun jobs found by the above query will need to be deleted or changed

to remove the email.

Delete Logs

In addition, some log files may need to be addressed by your system

administrator:

Windows Event Viewer - This will expire automatically.

WFM Event Viewer - this will expire automatically (based on system clean-

up).

AMR log - This isn't always enabled, but if it is, it will need to be manually

deleted by your system administrator.

RTA log - This will need to be deleted by your system administrator.

IIS log - This isn't always enabled, but if it is, this will expire automatically.

WFO log - this will expire automatically.
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WFMData log - this will expire automatically.

Right to Data-Portability

Workforce Management satisfies the right to data-portability by providing the

tools and procedures documented in this article.

View Employee Information

You can view employee information using the Employee Records module in

Workforce Management.

The following modules are used to add, view, and change the information for

individual and multiple employees, including their IDs and status information,

extra field information, employee group assignments, and schedule

preferences.

The primary modules for viewing employee information are:

Employee Records, which lets you add, view, and operate on individual or

multiple employees in a master list. You enter and view each employee's

information using the Employee Information form.

Employee Information form, which provides a quick way to edit a single

employee record.

Employee Reports, which allows you to view user-selected information on

each of your employees.

The Employee Information Form

Use the Employee Information form to enter and view information about a

specific employee. This form is accessible from several modules.

Enter the information on the following pages, as needed:

General—Enter the essential identification and status information about

this employee, such

as name, ID, email address, and hire date.

Extra Information—Enter extra information about the employee on one or

more extra

information pages set up by an administrator.
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Group Assignments—Assign the employee to one or more employee

groups.

Skills—Enter the employee’s skill associations.

ACD Login ID—Enter the employee’s ACD login IDs (optional).

Employee Information Reports

Aspect Workforce Management provides several employee information reports

you can preview,

print, and export. The following Employee Information reports are available:

Employee Information - E-mail Address - This report shows each

employee’s ID, name, seniority, hire date, termination date, and e-mail

address. Report details are grouped by employee group.

Employee Information - Extra Fields - This report shows each employee’s

name and seniority, plus as many as four employee extra fields. Report

details are grouped by employee group.

Employee Information - General - This report shows each employee’s ID,

name, seniority, hire date, termination date, and time zone. Report details

are grouped by employee group.

Employee Information - Instant Message Address - This report shows the

employee ID, name, seniority, hire date, termination date and instant

message address. Report details are grouped by employee group.

To create employee information reports, open the Reports module, select 

Employee Reports, then select Employee Information reports, and choose

the desired report, and select File >Print.

Previewing a report lets you see exactly how it will look when you print it. And,

while previewing, you can print or export the report at any time.

View User Information

You can view user information by accessing the Users Module in Workforce

Management. To access the Users Module, navigate to Administration > 

Access Control > Users. Complete the user name field to find a specific user,

or select the All check box and click the Retrieve button to display all users.

You can then view user information by double-clicking a user record.
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Right to Rectification

You can rectify erroneous information by editing employee and user data in

Workforce Management. This section describes the tools and processes that

Workforce Management provides in order to rectify data.

Edit an Employee

You can rectify employee information by using the Employee Information Form

as described in The Employee Information Form.

Edit a User

You can rectify user information using the Users module as described below.

To edit a user:

1. Open the Users module (File > Open) or select Administration > Access

Control > Users in the navigation tree.

2. Complete the user name field to find a specific user, or select the All

check box and click the Retrieve button to display all users.

3. Double-click the user to be edited, displaying the User form.

4. On the General Page, you can type over the User Name and Alternate

User Name.

5. On the Access Page, you can type over the Login ID, First name, and Last

name.

6. Click Save and Close when you are finished editing the user.

Back to top

Aspect Developer Portal overview

The Aspect Developer Portal modernizes how customers integrate with Cloud

Workforce by providing a fast, self-service experience. Developers can create

and manage applications, generate API credentials, explore interactive

documentation, and track usage—without submitting support tickets.

The portal reduces onboarding time from days to seconds, supports secure

and scalable integration, and lays the foundation for continuous innovation

through a growing catalog of REST APIs. With built-in features such as version
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tracking, real-time testing, and performance dashboards, the Developer Portal

helps teams build faster and with more confidence.

The Aspect Developer Portal is now available in the US, EU, UK, and Canada.

💡 Virtual Walkthrough

Click this link to see a virtual walkthrough of the Developer Portal. 

Key Features

Rapid Integration - Generate credentials and integrate applications in 30

seconds, replacing the previous multi-day process

REST API Capabilities - Access workforce data including:

Productivity metrics

Performance insights

Scheduling information

Developer Tools

Interactive API documentation

Usage dashboards

Figure 1-1
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Sandbox environment

Self-service credential management

HRIS Data Connect - a one-way integration that syncs employee time-off

types and balances from HR systems to Aspect WFM, eliminating duplicate

data entry and reducing compliance risk.

Fully automates the flow from HRIS to Aspect

Zero R&D investment required

Guided configuration (Connect → Map → Sync)

One-time setup keeps data automatically synced

Eliminates discrepancies between Employee hours scheduled and

worked

Reduces compliance risk and potential labor law related disputes

System Requirements

You must be an Aspect Cloud Workforce™ customer.

The Developer Portal is available in the US, UK, EU, and Canada.

Register your Aspect Developer Portal account                                                     

1. Open the invitation email and click Accept your invite to Workforce

Experience.
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✉️ The email will include your Account name for logging into the Aspect

Developer Portal. The email will expire after 7 days. If the email

expires, contact your Account Manager to resend the email.

2. You will be redirected to the Let’s Get Started page. 

⚠️ When Federated Login is enabled on your account, you will not be

required to register or to create and confirm a password. You will be

redirected to your company's authentication provider to verify your

identity. If you have already authenticated in your current browser

session, you will be automatically logged into the New Experience. 

3. Type your first and last name. 

4. The account name will be preselected for you. 

5. Select an answer from the drop-down menu that describes your work.

6. Create and confirm a password. 

7. When you are finished, click Get Started.

Figure 1-1
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8. You will receive a verification email. Open the email and verify the account.

The next time you need to log in, visit the Aspect Developer Portal login

page. 

Figure 1-2
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Back to top

Log in to the Aspect Developer Portal

1. Open the Aspect Developer Portal. Select or type your Account name,

then click Continue.

Figure 1-3
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2. Type your email and password, then click Login. See how to create and

view an Application.

⚠️ When Federated Login is enabled on your account, you will be

redirected to your company's authentication provider to verify your

identity. If you have already authenticated in your current browser

session, you will be automatically logged into the New Experience. 

Figure 1-1

Figure 1-2
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Back to top

Dashboard overview

The Aspect Developer Portal dashboard is divided into four main sections:

Apps: The Apps section displays the current list of Apps on the account.

From here, you can view the App name or description, the App ID, or see

the last time it was updated. You can also edit or delete an App. 

API Catalog: The API Catalog section provides details about Authentication

and Pagination. The API Catalog contains detailed documentation for all

available APIs, including the following for each API:

API definition

Query Parameters

Responses

Integrations: Provides a one-way integration that syncs employee time-off

types and balances from HR systems to Aspect WFM, eliminating duplicate

data entry and reducing compliance risk.

Usage: The Usage section allows you to monitor API and/or Apps usage

through intuitive graphs and tables that display activity patterns across

daily, weekly, and monthly timeframes.

Invite an Admin to your account

Admins will have unrestricted access for inviting other admins and

removing users. 

1. Open the Aspect Developer Portal and log in. 

2. Expand Admin, click User management and in the upper-right corner,

click Invite Admin. 
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3. Type the Admin email address and click Invite. 

Federated tenant: Admin will appear with Available status and change

to Active when they log in. 

Unfederated tenant: Admin will receive an invitation email with login

instructions. 

⚠️ For Unfederated tenants, invites expire after 7 days. If the invite

expires, resend the invite. Sending admin invites in bulk is not

available yet but will be added soon. 

Figure 1-1
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4. To resend an invite, locate the user's row and click the Resend icon in the 

Actions column. To delete an invite, locate the user's row and click the 

Trash icon in the Actions column.

The Status column shows the current status of all users in your

account. Use the navigation buttons at the bottom to view all users.

Active: The user has accepted the invite email and has an active

account.

Pending: The user has not accepted the invite email and does not have

an active account.

Figure 1-2
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Back to top

Apps 💻
Create an App with automatically generated credentials

💡 Create, edit, or delete Apps in just a few clicks. The system

automatically generates credentials for each new App. Before you

create an App, we suggest exploring the API catalog.

1. Log into the Aspect Developer Portal.

2. Expand Developer and click Apps.

Figure 1-3
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3. Click Create App in the middle of the screen. If you have already created

an App, click Create App in the upper-right corner.

4. Enter an App Name and App Description, then click Create App. 

Figure 1-1

Figure 1-2
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5. Click the Copy icon next to the App ID, Client ID and Client Secret and

paste the links somewhere you can reference at a later time. Optionally,

you can manually write the credentials down.

⚠️ The generated credentials (Client ID and Client Secret) can only be

viewed once they are initially created, but you can still generate new

credentials if needed. 

Figure 1-3

Figure 1-4
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6. Click Save App.

7. The new App will appear in the Apps screen. You can see the App name,

description, ID, and updated/created times. See how to edit or delete an

App.

Back to top

Figure 1-5

Figure 1-6
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Edit or Delete an App

You can update your App's name, description, and re-create credentials at

any time. All changes are logged for tracking.

1. Log into the Aspect Developer Portal.

2. Expand Developer and click Apps.

3. On the right side of the screen, click the pencil icon to edit an App, or click

the trash icon to delete an App. 

Figure 1-1
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Edit an App

a. Click the pencil icon next to the App you want to edit.

b. You can edit the Name or Description. 

c. Optionally, to create new credentials, click Generate New Client

ID/Client Secret Credentials > Generate New Credentials. 

⚠️ By generating a new set of Client ID/Client Secret credentials,

any previous Client ID/Client Secret credentials will no longer

work. 

Figure 1-2
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d. The new credentials will appear. Click the Copy icon next to both the 

Client ID and Client Secret, then save them in a secure location for future

reference. You can also write down the credentials manually. 

e. Click Save App. The new credentials will be applied to the App.

Delete an App

a. Click the trash icon next to the App you want to delete.

Figure 1-3

Figure 1-4
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b. Verify you want to delete the selected App and click Confirm. The app

will be removed from the Apps screen.

All users have Admin privileges and can delete any App in the

Developer Portal.

Back to top

Re-Generate New Credentials for an App (Client ID/Client Secret)

1. Log into the Aspect Developer Portal.

2. Expand Developer and click Apps.

Figure 1-5

Figure 1-1
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3. On the right side of the screen, click the pencil icon next to the App for

which you want to generate new credentials. 

4. Make any edits to the App Name and App Description fields and click 

Generate New Client ID/Client Secret Credentials > Generate New

Credentials. 

⚠️ By generating a new set of Client ID/Client Secret credentials, any

previous Client ID/Client Secret credentials will no longer work. 

Figure 1-2
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5. The new credentials will appear. Click the Copy icon next to both the 

Client ID and Client Secret, then save them in a secure location for future

reference. You can also write down the credentials manually. 

6. Click Save App. The new credentials will be applied to the App.

Back to top

Explore the Sandbox environment

Figure 1-3

Figure 1-4
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1. Log in to the Aspect Developer Portal.

2. Expand Developer, click API Catalog, then click the API that you want to

test in the Sandbox and click Test Request. In this example, we are testing

the Search Employees API.

3. Confirm the following configuration settings in the Search Employees

Definitions fields and click Authorize.

a. Authentication

b. Cookies

c. Headers

d. Query Parameters

e. Query Call Body (JSON)

Figure 1-1
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4. The Client Secret and Client ID are automatically generated, click 

Authorize.

Figure 1-2
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5. The Access Token is automatically generated. Click Send to make an API

call. On the right side of the screen you will see the API call response:

➡️ The JSON code used is the default example provided with the API

endpoint in the API catalog.

Figure 1-3
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Back to top

API Catalog 📚
Explore the API catalog

💡 The Aspect Cloud Workforce REST API enables developers to create

Apps that retrieve, create and update information related to their

workforce productivity, Intra-Day Performance (IDP) and schedule

entities. 

Users can browse available APIs, review detailed documentation,

and test APIs directly within the portal.

1. Log in to the Aspect Developer Portal, expand Developer and click API

Catalog.

Figure 1-4

Aspect Developer Portal 33

https://www.notion.so/9c3c9f94cd07821da41781368b953136?pvs=25#4b8c9f94cd07838cb4ff81a84e8eb965


2. Click Authentication and view the related information.

The API uses oAuth2 Client Credentials flow where you obtain an

authorization token from tokenUrl using either client_secret_basic or

client_secret_post methods. For the recommended client_secret_basic

method, you send a POST request with base64-encoded credentials

and required parameters. 

After obtaining your Client ID and Client Secret from the Developer

Portal, you can authenticate by filling in credentials, selecting scopes,

and clicking Authorize to set up the Access Bearer token for test

requests.

Figure 1-1
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4. Click Pagination and large result sets and view the related information.

The API supports pagination through startIndex and maxResults

parameters, with configurable service-specific limits for result sets. 

When dealing with large data volumes, it's recommended to use

multiple focused queries instead of paging through a single large result

set, such as breaking down schedule requests by date or employee.

Since most data changes infrequently, high-frequency synchronization

of large data volumes should be avoided as it can impact system

performance.

Figure 1-2

Figure 1-3
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Back to top

View Segments

💡 Endpoints for managing segments and associated entities. 

Operations

POST/v1/search/segments (Search Segments)

POST/v1/search/segmentDefinitions (Search Segment Definitions)

POST/v1/search/segmentCategories (Search Segment Categories)

POST/v1/search/segmentSummaries (Search Segment Summaries)

POST/v1/search/segmentAudits (Search Segment Audits)

POST/v1/segments (Create Segments)

PUT/v1/segments (Update Segments)

POST/v1/segments/delete (Delete Segments)

Search Segments

Retrieves a list of segments that match the specified selector. 

1. Click API Catalog > Segments > Search Segments. You will see the

following:

API definition

Query Parameters

Segments to retrieve

Responses

Sandbox environment for testing
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Search Segment Definitions

Retrieves a list of segment definitions that match the specified selector.

1. Click API Catalog > Segments > Search Segment Definitions. You will see

the following:

API definition

Query Parameters

Segment definitions to retrieve

Responses

Sandbox environment for testing

Figure 1-1
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Search Segment Categories

Retrieves a list of segment categories that match the specified selector.

1. Click API Catalog > Segments > Search Segment Categories. You will see

the following:

API definition

Query Parameters

Segment categories to retrieve

Responses

Sandbox environment for testing

Figure 1-2
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Search Segment Summaries

Retrieves a list of segment summaries that match the specified selector.

1. Click API Catalog > Segments > Search Segment Summaries. You will

see the following:

API definition

Query Parameters

Segment summaries to retrieve

Responses

Sandbox environment for testing

Figure 1-3
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Search Segment Audits

Retrieves a list of segment audits that match the specified selector.

1. Click API Catalog > Segments > Search Segment Audits. You will see the

following:

API definition

Query Parameters

Segment summaries to retrieve

Responses

Sandbox environment for testing

Figure 1-4
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Create Segments

You can create segments directly to the schedule or submit them as

requests, with each segment requiring specific elements like employee ID,

date, code, times, type, and memo. The saveAsRequest flag determines

whether the segment becomes an official part of the employee's schedule

immediately or is submitted as a request for approval.

1. Click API Catalog > Segments > Create segments. You will see the

following:

API definition

Segments to create

Responses

Sandbox environment for testing

Figure 1-5
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Update Segments

Updates to existing official schedule segments require both the current

segment (retrieved using POST /v1/search/segments) and the update

segment containing all property values, even unchanged ones. The

saveAsRequest flag determines whether the update is applied directly to

the official segment or submitted as a request for approval, with error

messages provided if the current segment version doesn't match the

database.

1. Click API Catalog > Segments > Update segments. You will see the

following:

API definition

Segments to update

Responses

Sandbox environment for testing

Figure 1-6
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Delete Segments

Delete segments either directly from the schedule or submit them as

requests to be reviewed. Each segment requires specific elements

including employee ID, nominal date, code, start/stop times (for detail

segments only), type, and memo, with a saveAsRequest flag that

determines whether it becomes an official schedule segment or a request

for approval.

1. Click API Catalog > Segments > Delete segments. You will see the

following:

API definition

Segments to delete

Responses

Sandbox environment for testing

Figure 1-7
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Back to top

View Schedules

💡 Endpoints for managing schedules and associated entities. 

Operations

POST /v1/search/scheduleTimePeriodResolution (Search Schedule Time

Period Resolutions)

Search Schedule Time Period Resolutions

Retrieves employee schedule time period resolution from WFM.

1. Click API Catalog > Schedules > Search Schedule Time Period

Resolutions. You will see the following:

API definition

Query parameters

Time period resolutions to retrieve

Figure 1-8
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Responses

Sandbox environment for testing

View Employees

💡 Endpoints for managing employees and associated entities. 

Operations

POST /v1/search/employees (Search Employees)

POST /v1/search/employeeSkills (Search Employee Skills)

POST /v1/search/employeeGroups (Search Employee Groups)

POST /v1/search/employeeSuperGroups (Search Employee

SuperGroups)

GET /v1/employeeGroupClasses (Get Employee Group Classes)

GET /v1/employeeExtraFields (Get Employee Extra Fields)

GET /v1/employeeExtraFieldTabs (Get Employee Extra Field Tabs)

PUT /v1/employees (Update Employees)

PUT /v1/employeeStatuses (Update Employee Statuses)

Figure 1-1
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POST /v1/search/employeePersonalAccounts (Search Personal

Accounts)

POST /v1/employeePersonalAccountBalances (Search Personal Account

Balances)

PUT /v1/employeePersonalAccountBalances (Update Personal Account

Balances)

Search Employees

Retrieves a list of employees that match the specified selector.

1. Click API Catalog > Employees> Search Employees. You will see the

following:

API definition

Query parameters

Employee parameters to retrieve

Responses

Sandbox environment for testing

Figure 1-1
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Search Employee Skills

Retrieves a list of employee skills that match the specified selector.

1. Click API Catalog > Employees > Search Employee Skills. You will see the

following:

API definition

Query Parameters

Employee skills to retrieve

Responses

Sandbox environment for testing

Search Employee Groups

Retrieves a list of employee groups that match the specified selector.

1. Click API Catalog > Employees > Search Employee Groups You will see

the following:

Figure 1-2
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API definition

Query Parameters

Employee groups to retrieve

Responses

Sandbox environment for testing

Search Employee SuperGroups

Retrieves a list of employee supergroups that match the specified selector.

1. Click API Catalog > Employees > Search Employee SuperGroups. You will

see the following:

API definition

Query Parameters

Employee SuperGroups to retrieve

Responses

Sandbox environment for testing

Figure 1-3
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Get Employee Group Classes

Retrieves all employee group classes.

1. Click API Catalog > Employees > Get Employee Group Classes. You will

see the following:

API definition

Query Parameters

Responses

Sandbox environment for testing

Figure 1-4
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Get Employee Extra Fields

Retrieves all employee extra fields.

1. Click API Catalog > Employees > Get Employee Extra Fields. You will see

the following:

API definition

Query Parameters

Responses

Sandbox environment for testing

Figure 1-5
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Get Employee Extra Field Tabs

Retrieves all employee extra field tabs.

1. Click API Catalog > Employees > Get Employee Extra Field Tabs. You will

see the following:

API definition

Query Parameters

Responses

Sandbox environment for testing

Figure 1-6
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Update Employees

Updates a list of employees that match the specified updater.

1. Click API Catalog > Employees > Update Employees. You will see the

following:

API definition

Employees to update

Responses

Sandbox environment for testing

Figure 1-7
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Update Employee Statuses

Updates the employment status and/or active status of one or more

employees.

1. Click API Catalog > Employees > Update Employee Statuses. You will see

the following:

API definition

Employee statuses to update

Responses

Sandbox environment for testing

Figure 1-8
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Search Personal Accounts

Retrieves a list of personal accounts that match the specified selector.

1. Click API Catalog > Employees> Search Personal Accounts. You will see

the following:

API definition

Query parameters

Personal account parameters to retrieve

Responses

Sandbox environment for testing

Figure 1-9
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Search Personal Account Balances

Retrieves a list of personal account balances that match the specified

selector.

1. Click API Catalog > Employees> Search Personal Account Balances You

will see the following:

API definition

Query parameters

Personal account balance parameters to retrieve

Responses

Sandbox environment for testing

Figure 1-10
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Update Personal Account Balances

Updates a list of personal account balances that match the specified

selector.

1. Click API Catalog > Employees> Update Personal Account Balances. You

will see the following:

API definition

Query parameters

Personal account balance parameters to update

Responses

Sandbox environment for testing

Figure 1-11
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Back to top

View IDP (Intra-Day Performance)

💡 Endpoints for intra-day performance and associated entities. 

Operations

POST /v1/search/idpSummaries (Search IDP Summaries)

POST /v1/search/staffGroup (Search Staff Groups)

GET /v1/search/staffGroup (Get Staff Groups)

POST /v1/search/idpForecasts (Search IDP Forecasts)

GET /v1/search/idpForecasts (Get IDP Forecasts)

POST /v1/search/idp/details (Search IDP Details)

GET /v1/search/idp/details (Get IDP Details)

POST /v1/idp/{id} (Search IDP)

Search IDP Summaries

Figure 1-12
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Retrieves a list of intra-day performance summaries that match the

specified selector.

1. Click API Catalog > IDP > Search IDP Summaries. You will see the

following:

API definition

Query parameters

Intra-day performance summaries to retrieve

Responses

Sandbox environment for testing

Search Staff Groups

Retrieves a list of detailed information about staff groups that matches the

specified selector.

1. Click API Catalog > IDP > Search Staff Groups. You will see the following:

Figure 1-1
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API definition

Query parameters

Detailed information about staff groups to retrieve

Responses

Sandbox environment for testing

Get Staff Groups

Retrieves the list of cached detailed information about staff groups that

matches the searchId from the original POST.

1. Click API Catalog > IDP > Get Staff Groups. You will see the following:

API definition

Query parameters

Responses

Sandbox environment for testing

Figure 1-2
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Search IDP Forecasts

Retrieves a list of detailed information about IDP forecasts that matches

the specified selector.

1. Click API Catalog > IDP > Search IDP Forecasts. You will see the following:

API definition

Query parameters

Detailed information about IDP forecasts to retrieve

Responses

Sandbox environment for testing

Figure 1-3
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Get IDP Forecasts

Retrieves the list of cached detailed information about idp forecasts that

matches the searchId from the original POST.

1. Click API Catalog > IDP > Get IDP Forecasts. You will see the following:

API definition

Query parameters

Responses

Sandbox environment for testing

Figure 1-4
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Search IDP Details

Retrieves a list of detailed information about IDP forecast details that

matches the specified selector.

1. Click API Catalog > IDP > Search IDP Details. You will see the following:

API definition

Information about IDP forecast details to retrieve

Responses

Sandbox environment for testing

Figure 1-5
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Get IDP Details

Retrieves a list of detailed information about IDP forecast details that

matches the specified selector.

1. Click API Catalog > IDP > Get IDP Details. You will see the following:

API definition

Query parameters

Responses

Sandbox environment for testing

Figure 1-6
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Search IDP

Retrieves an intra-day performance that matches the id and specified

selector.

1. Click API Catalog > IDP > Search IDP. You will see the following:

API definition

Path parameters

IDP parameters to retrieve

Responses

Sandbox environment for testing

Figure 1-7
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Back to top

View State

💡 Endpoints for managing superstate hours for groups of employees

and associated entities

Operations

POST /v1/search/superStateHours (Search Superstate Hours)

POST /v1/search/superStates (Search Super States)

Search Superstate Hours

Retrieves a list of superstate hours that match the specified selector.

1. Click API Catalog > State > Search Superstate Hours. You will see the

following:

API definition

Query parameters

Figure 1-8
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Superstate hours to retrieve

Responses

Sandbox environment for testing

Search Super States

Retrieves a list of super states that match the specified selector.

1. Click API Catalog > State > Search Super States. You will see the

following:

API definition

Query parameters

Super States to retrieve

Responses

Sandbox environment for testing

Figure 1-1
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Back to top

View Adherence

💡 Endpoints for managing adherence and associated entities.

Operations

POST /v1/search/adherences (Search Adherences)

Search Adherences

Retrieves a list of adherence records that match the specified selector.

1. Click API Catalog > Adherence > Search Adherences. You will see the

following:

API definition

Query parameters

Adherences to retrieve

Responses

Figure 1-2
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Sandbox environment for testing

View WFM System

💡 Endpoints for managing the Workforce Management (WFM) system

settings and associated entities.

Operations

GET /v1/adminCurrentTime (Get System Time)

GET /v1/systemParameters (Get System Parameters)

GET /v1/systemInformation (Get System Information)

GET /v1/timeZones (Get Time Zones)

Get WFM System Time

Figure 1-1
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Retrieves WFM system time information including: a timestamp of the

current system time from the database, the request server's local system

time, the current time in UTC, timezones for both the Aspect Cloud

Workforce database and server, and the current time expressed in any

timezone(s) specified in the request. 

1. Expand Developer and click API Catalog > WFM System > Get System

Time. You will see the following:

API definition

Responses

Sandbox environment for testing

Get System Parameters

Retrieves a list of system parameters that match the name list.

1. Expand Developer and click API Catalog > WFM System > Get System

Parameters. You will see the following:

Figure 1-1
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API definition

Query parameters

Responses

Sandbox environment for testing

Get System Information

Retrieves information about the state and configuration of the Workforce

component. 

1. Expand Developer and click API Catalog > WFM System > Get System

Information. You will see the following:

API definition

Responses

Sandbox environment for testing

Figure 1-2
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Get Time Zones

Retrieves WFM time zones.

1. Expand Developer and click API Catalog > WFM System > Get Time

Zones. You will see the following:

API definition

Query parameters

Responses

Sandbox environment for testing

Figure 1-3
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Back to top

View Agent 

💡 Endpoints for managing agent productivities and associated entities

Operations

POST /v1/search/agentProductivities (Search Agent Productivities)

GET /v1/agentProductivityAcdGroups (Get Agent Productivity ACD

Groups)

POST /v1/search/agentFormulaSets (Search Agent Formula Sets)

Search Agent Productivities

Retrieves a list of agent productivities that match the specified selector.

1. Expand Developer and click API Catalog > Agent > Search Agent

Productivities. You will see the following:

API definition

Figure 1-4
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Query parameters

Agent productivities to retrieve

Responses

Sandbox environment for testing

Get Agent Productivity ACD Groups

Retrieves WFM Agent productivity ACD groups. 

1. Expand Developer and click API Catalog > Agent > Get Agent

Productivity ACD Groups. You will see the following:

API definition

Query parameters

Responses

Sandbox environment for testing

Figure 1-1
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Search Agent Formula Sets

Retrieves a list of Agent formula sets that match the specified selector.

1. Expand Developer and click API Catalog > Agent > Search Agent Formula

Sets. You will see the following:

API definition

Query parameters

Agent formula sets to retrieve

Responses

Sandbox environment for testing

Figure 1-2
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Back to top

View Perspectives

💡 Endpoints for managing perspectives and associated entities. 

Operations

POST /v1/search/perspectives (Search Perspectives)

GET /v1/perspectivePurposes (Get Perspective Purposes)

Search Perspectives

Retrieves a list of perspectives that match the specified selector.

1. Expand Developer and click API Catalog > Perspectives > Search

Perspectives. You will see the following:

API definition

Query parameters

Perspectives to retrieve

Figure 1-3
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Responses

Sandbox environment for testing

Get Perspective Purposes

Retrieves WFM perspective purposes

1. Expand Developer and click API Catalog > Perspectives > Get

Perspective Purposes. You will see the following:

API definition

Query parameters

Responses

Sandbox environment for testing

Figure 1-1
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Back to top

View Staff

💡 Endpoints for managing staff and associated entities

Operations

POST /v1/search/staffAdjustmentSets (Search Staff Adjustment Sets)

POST /v1/search/staffGroups (Search Staff Groups)

Search Staff Adjustment Sets

Retrieves a list of staff adjustment sets that match the specified selector.

1. Expand Developer and click API Catalog > Staff > Search Staff

Adjustment Sets. You will see the following:

API definition

Query parameters

Staff Adjustment sets to retrieve

Figure 1-2
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Responses

Sandbox environment for testing

Search Staff Groups

Retrieves a list of staff groups that match the specified selector.

1. Expand Developer and click API Catalog > Staff > Search Staff Groups.

You will see the following:

API definition

Query parameters

Staff groups to retrieve

Responses

Sandbox environment for testing

Figure 1-1
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Back to top

View ACD

💡 Endpoints for managing ACDs and associated entities.

Operations

POST /v1/search/acdInstances (Search ACD Instances)

Search ACD Instances

Retrieves a list of ACD instances match the specified selector.

1. Expand Developer and click API Catalog > ACD > Search ACD instances.

You will see the following:

API definition

Query parameters

ACD instances to retrieve

Responses

Figure 1-2
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Sandbox environment for testing

View Routing

💡 Endpoints for managing Routing sets and associated entities.

Operations

POST /v1/search/routingSets (Search Routing Sets)

Search Routing Sets

Retrieves a list of routing sets that match the specified selector.

1. Expand Developer and click API Catalog > Routing > Search Routing Sets.

You will see the following:

API definition

Query parameters

Routing sets to retrieve

Figure 1-1

Aspect Developer Portal 80

https://www.notion.so/9c3c9f94cd07821da41781368b953136?pvs=25#998c9f94cd07822bb3bb817b6ff52619


Responses

Sandbox environment for testing

View Forecast 

💡 Endpoints for managing forecast groups and associated entities.

Operations

POST /v1/search/forecastGroups (Search Forecast Groups)

POST /v1/search/forecasts (Search Forecast)

POST /v1/search/forecastdetails (Search Forecast Details)

Search Forecast Groups

Retrieves a list of adherence records that match the specified selector.

1. Expand Developer and click API Catalog > Forecast > Search Forecast

Groups. You will see the following:

Figure 1-1
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API definition

Query parameters

Forecast groups to retrieve

Responses

Sandbox environment for testing

Search Forecasts

Search & retrieves all available forecasts for selected forecasting group

with it's basic data entities that match the specified selector.

1. Expand Developer and click API Catalog > Forecast > Search Forecasts.

You will see the following:

API definition

Query parameters

Forecasts to retrieve

Responses

Figure 1-1
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Sandbox environment for testing

Search Forecast Details

Search & retrieves forecast detail data for selected forecast group that

match the specified selector.

1. Expand Developer and click API Catalog > Forecast > Search Forecast

Details. You will see the following:

API definition

Query parameters

Forecasts details to retrieve

Responses

Sandbox environment for testing

Figure 1-2
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View Models

1. Expand Developer and click API Catalog > Models. 

2. Expand each model to see the details.

View Use Case content

Figure 1-3

Figure 1-1
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Aspect Developer Portal - Workforce Rest APIs

Aspect Developer Portal APIs enable seamless integration of Workforce

Management (WFM) data with other business applications, allowing

organizations to optimize workforce planning, scheduling, and performance

tracking.

Key benefits of searching, retrieving and updating WFM data via API’s:

Access real-time and historical workforce data for decision-making

Customize data extraction and/or data insert based on specific needs

(e.g., for different teams or time periods)

Reduce manual efforts by automating data search, retrieval & update

WFM data Use Case Scenario
Suggested API

Endpoints

Estimated API

calls -

day/week/month

Employee

Schedules

Third-party contact

center and/or HRIS

system needs to

search & retrieve

employee

schedules from

WFM.

Listed

functionalities

allows complete

access to up-to-

date shift schedules

for workforce

planning.

Can also be utilized

to populate

schedule

information in

external calendars

or HRIS systems or

scheduling tools.

Segments

• Search Segments

• Search Segment

Definitions

Employees

• Search Employees

Perspectives

• Search Perspectives

(optional/if need state

info)

4/28/120
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WFM data Use Case Scenario
Suggested API

Endpoints

Estimated API

calls -

day/week/month

Employee Data &

Agent

Productivity

Data

Business wants

agent productivity

insights for tracking

and evaluation.

WFM provides work

hours, login/logout

times, and other

agent productivity

metrics.

Employees

• Search Employees

• Search Employee

Groups (optional/if need

employee groups info)

• Search Employee Skills

(optional/if need

employee skills info)

• Get Employee Extra

Fields (optional/if need

employee extra fields

info)

Agent

• Search Agent

Productivities

• Get Agent Productivity

ACD Groups (optional/if

need AcdGroups info)

ACD

• Search ACD Instances

WFM System

• Get Time Zones

(optional/if need

employee time zone

info)

8/56/240

Intra-Day

Performance

Metrics

Contact center

system wants to

monitor real-time

KPIs for workforce

optimization.

WFM provides

access to Intra-Day

performance

Employees

• Search Employees

IDP

• Search IDP Summaries

Routing

• Search Routing Sets

5/35/150
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WFM data Use Case Scenario
Suggested API

Endpoints

Estimated API

calls -

day/week/month

metrics (e.g., call

handling metrics).

Forecast

• Search Forecast

Groups

Staff

• Search Staff Groups

Agent

Adherence

Tracking

Track agent

schedule adherence

in real-time for

compliance and

optimization.

WFM provides real-

time adherence

data comparing

scheduled vs.

actual agent

activity.

Can be utilized to

populate third-party

systems like

performance

monitoring

dashboards with

adherence data.

Can be utilized to

extract non-

adherent agents for

coaching

opportunities.

Can be utilized to

generate automated

alerts for adherence

violations (e.g., late

Employees

• Search Employees

• Get Employee Extra

Fields (optional/if need

employee extra fields

info)

Adherence

• Search Adherences

Perspectives

• Search Perspectives

4/28/120
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WFM data Use Case Scenario
Suggested API

Endpoints

Estimated API

calls -

day/week/month

logins, extended

breaks).

Employee Time

Off Types and

Balances

(Personal

Account Types

and Balances)

WFM provides

search, retrieve and

update

functionalities for

each employee

personal account

type & balance data.

Third-party systems

(HRIS, Payroll,..) can

utilize those

functionalities to

automate & sync

processes for their

employee Timeoff

types (vacation,

sick leave, ..) and

Balances. Any

TimeOff Type &

balance change on

third-party system

would automatically

be updated on WFM

system, for all

mapped Employees

(and vice-versa).

Note: Specific data

updates on third-

party systems are

subject to

availability and in

complete controlled

by those third-party

system.

Employees

• Search Employees

• Get Employees Extra

Fields (optional/if need

employee extra fields

info)

• Search Personal

Accounts

• Search Personal

Account

Balances

• Update Personal

Account Balances

5/35/150
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WFM data Use Case Scenario
Suggested API

Endpoints

Estimated API

calls -

day/week/month

Employee

Worked Hours

WFM provides

search & retrieve

functionalities for

each Employee

scheduled and

worked time period.

Details like

Segments

overlapping with

Perspective are also

available.

Third-party systems

(HRIS, Payroll,…)

can utilize listed

WFM functionalities

to automate data

processes of search

& retrieve WFM

scheduled and

worked hours for

each Employee, and

update those hours

on Payroll system.

Automating this

data process

between WFM and

third-party system

will eliminate

discrepancies

and/or duplicate

data entries for

scheduled, worked

and paid Employee

hours.

Furthermore, it will

Segments

• Search Segments

Employees

• Search Employees

• Get Employees Extra

Fields (optional/if need

employee extra fields

info)

• Search Employee

Groups (optional/if need

employee groups info)

• Search Employee Skills

(optional/if need

employee skills info)

Perspectives

• Search Perspectives

Schedule

• Search Schedule Time

Period Resolutions

7/28/210
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WFM data Use Case Scenario
Suggested API

Endpoints

Estimated API

calls -

day/week/month

reduce compliance

risk and potential

labor law related

disputes.

Legacy Reference Guides

Hosted and Premise Workforce SDK (only applicable for hosted and

premise deployments) 

Back to top

Integrations 🔌
Connect, Map and Sync HRIS Data Connection

Overview

HRIS Data Connect is a one-way integration that syncs employee time-off

types and balances from HR systems to Aspect WFM, eliminating duplicate

data entry and reducing compliance risk. HRIS Data Connect includes the

following benefits:

Fully automates the flow from HRIS to Aspect

Zero R&D investment required

Guided configuration (Connect → Map → Sync)

One-time setup keeps data automatically synced

Eliminates discrepancies between Employee hours scheduled and

worked

Reduces compliance risk and potential labor law related disputes

Aspect Developer Portal 90

https://help.aspect.com/go/aspect/premiseportfolio.wem.24.workforce24.developer.sdkdeveloper&SCR=1738895887569
https://www.notion.so/9c3c9f94cd07821da41781368b953136?pvs=25#35fc9f94cd0780208ecac51a2a75b647


💡 There are four parts to setting up HRIS data connect from the

Developer Portal:

1. Connect to HRIS

2. Map the Employee Time Off Types

3. Map the Employees by name and email

4. Schedule Sync

I. Connect to HRIS

1. Log into the Aspect Developer Portal.

2. Expand Developer, select Integrations and click Add Integration.

3. Next to BambooHR > Aspect WFM, click Set up integration > Configure.

Figure 1-1
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💡 The integration currently supports BambooHR, with plans to add

Workday HCM and ADP Workforce Now in the future.

4. In the Connect to BambooHR section, fill in the fields and test the

connection.

a. In the Company Domain field, type the name of your company domain

(how it's defined in BambooHR).

b. In the API Key field, copy/paste the API key that was auto generated

from the BambooHR software.

c. Click Test Connection. After a Successful Connection, click Next. 

Figure 1-2
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⚠️ If the connection is unsuccessful, an error message will appear.

The message describes whether you should enter the correct

company domain and API key values or contact BambooHR

support.

II. Map the Employee Time Off Types

1. In the Field mapping section, fill in the fields to map the source HRIS data

to the destination WFM data. Add at least one entry to continue to the next

step. You can add as many time off types as needed.

a. From the Time Off Type drop-down menu on the left side, select an

option for the source HRIS data field.

b. From the Personal Account Type drop-down menu on the right side,

select an option for the destination WFM data field.

Figure 1-3

Aspect Developer Portal 93



c. Select an option (Hours or Days) from the Measurement Unit drop-

down menu.

d. Type a value in the Work Hours Per Day field.

e. Review your field mapping data and click Confirm Field Mapping.

Optionally, click Add Type to add another entry before continuing.

III. Map the Employees by name and email

Figure 2-1
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💡 The system will automatically map employees using first name, last

name, and email. Next to Matched Fields, you can see how many

employees were mapped automatically. For those who were not

automatically mapped, you will need to map them manually. This is a

one-time process.

If new employees are added to BambooHR and also added to Aspect

WFM, you must edit the HRIS integration and confirm the

automatically mapped employees or manually map any newly added

employees that were not mapped.

1. In the Employee mapping section, fill in the fields to map the Employee

source email address to the destination WFM email address. 

a. Use the filter option to navigate to a specific employee.

b. Select an email address under the WFM Employee and confirm that it

matches the same email address under Email.

c. When you are done, click Confirm Employee Mapping.
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IV. Schedule Sync

💡 Syncing allows you to determine when the data should be imported

from HRIS to WFM. There are two ways you can schedule syncs:

Manual or Scheduled.

Manual Sync

1. Select Manual.

2. Click the Manual Sync button anytime from this page to perform a

Manual Sync.

3. Click Add Integration and Schedule Sync.

Figure 3-1
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4. After a successful sync, you will be redirected to the Integrations view

where you can see your new HRIS connection. See how to edit,

disable, or delete the connection.

Scheduled Sync

1. Select Schedule.

2. From the Sync start drop-down menu, select a time to start the sync.

3. From the Sync Interval drop-down menu, select an interval option.

4. Click Add Integration and Schedule Sync.

Figure 4-1
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5. After a successful sync, you will be redirected to the Integrations view

where you can see your new HRIS connection. See how to edit,

disable, or delete the connection.

Edit, Disable or Delete your HRIS Connection

Edit an HRIS connection

Figure 4-2
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⚠️ You cannot save mapping edits (Field and Employee) while a

sync is in progress. The Save button is inactive.

When you change the company domain, you must complete

the entire process (connect, map, sync) and then save your

changes.

When you change the API key, you must reconnect and save

your changes. You do not need to remap or change the sync

setting.

When you change the mapping, you only need to save your

changes. You do not need to change the sync setting.

When you change the sync settings, you only need to save

your changes.

1. Log into the Aspect Developer Portal.

2. Expand Developer, select Integrations and click Configure.
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3. Click the panel you want to update (Connect, Map Fields, Map

Employees, Sync), then make your edits. When you are finished, click 

Save to apply the changes to your HRIS connection.

Figure 5-1
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Disable an HRIS connection

1. Log into the Aspect Developer Portal.

2. Expand Developer, select Integrations and click Configure.

Figure 5-2
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3. Under the Connect tab, click Disable integration. 

Figure 6-1
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4. Click Disable integration again to disable the connection. Optionally,

click Cancel to return to the edit screen.

Delete an HRIS connection

Figure 6-2

Figure 6-3
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⚠️ Deleting the HRIS integration stops all future data exchange

between the HRIS and WFM. Previously received data is not

changed.

All configured and saved integration data (connect, map, sync) is

deleted.

Employee balances for mapped time off types that were synced

from HRIS to WFM while the integration was active remain

available.

1. Log into the Aspect Developer Portal.

2. Expand Developer, select Integrations and click Configure.

3. Click Delete integration, type the required text and click Delete

integration. Optionally, click Cancel to return to the edit screen.

Figure 7-1
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 Back to top

Usage 📊
View API usage metrics

💡 Users can monitor API and/or Apps usage through intuitive graphs

and tables that display activity patterns across daily, weekly, and

monthly timeframes.

1. Log in to the Aspect Developer Portal.

2. Expand Developer and click Usage.

Figure 7-2
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3. In the top-right corner of the screen, you'll find date configuration settings.

From the drop-down menu, select Day, Week, Month, or Year to adjust

the time period. The default view/position should present usage data

for the current week.

Use the calendar menu to select a specific date or date range. 

The graphs and table below will automatically update to reflect your

selection.

Figure 1-1
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4. To create a filtered view of your usage metrics, select either By App or By

Endpoint.

By App shows you the number of API calls linked to each App (using

App credentials as linkage).

By Endpoint shows you the number of API calls per specific API

endpoint, also linked to each App.

4. Based on these selections, a graph and table showing your usage metrics

will appear in the center of the screen. 

Graph View By Endpoint: Shows sum of API calls per API endpoint for

selected day/week/month (breakdown by day).

Figure 1-2
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Graph View By App: Shows sum of API calls per App for the selected

day/week/month (breakdown by day). 

Table View by Endpoint: Shows usage breakdown based on the API

Endpoint name and number of API calls made using: 

App name

Figure 1-3

Figure 1-4
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API endpoint (linked to the App)

Total sum of all API calls per App name and per API endpoint (can

be filtered by descending or ascending order)

Table View By App: Shows usage breakdown based on App name and

number of API calls made using: 

App name

API endpoint (linked to the App)

Total sum of all API calls per App name and per API endpoint (can

be filtered by descending or ascending order)

Figure 1-5
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Back to top

FAQ 🔍
FAQs

How will new APIs be added to the Aspect Developer Portal over time? 

We will release new APIs in alignment with Aspect Cloud WFM priorities.

All new APIs will be announced via the portal homepage and changelog.

What are the system requirements for the Aspect Developer Portal?

See details in the system requirements section.

What capabilities does the Aspect Developer Portal provide that I don’t

get with Aspect Cloud Workforce?

Aspect Cloud Workforce is a software solution developed to manage

their workforce. 

Aspect Developer Portal is a self-serve gateway to Aspect Cloud

workforce data generated by the Aspect Cloud Workforce product. 

Figure 1-6
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How do I create or view an API?

See instructions for how to create or view an API. 

How do I edit an API?

See instructions for how to edit an API. 

How do I create or edit credentials?

See instructions for how to create or edit credentials. 

Where can I explore the API catalog?

See more details for how to explore the API catalog. 

How do I view API usage metrics?

See more details for how to view API usage metrics. 

How do I connect, map and sync my HRIS Data Connection?

See how to connect, map and sync your HRIS Data Connection.

Contact Support 🗣️
Contact Support

For any issues you are unable to resolve in the Troubleshooting section, please

log a support ticket via our support portal, and select Aspect Developer Portal

as the product. You can also contact your Workforce Administrator with your

account name and a description of your issue. 
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